Month: August 2015

Mikrotik Hotspot Shared User


Hello every one, Today article covered how to setup shared users in Mikrotik Hotspot Users Profile and assign Bandwidth among this group.

First of all you need to setup Mikrotik Hotspot and configured as you desire.

My Working Scenario is More Secure and reliable for theft bandwidth in Hotspot interface.

Router Wan Interface IP Address is 192.168.0.20/24

Router Lan Interface IP Address is 192.168.10.1/24 (Hotspot) Regular Users

Important Note: I am adding another IP Address for group users is 192.168.80.1/24 on Lan Interface and masquerade in IP FIREWALL NAT.

Now Create user profile for shared users i am giving 5 IP address to use same user name. Flexibility for users to use more devices such as Mobiles Phone / Laptop’s / Personal Computer’s Etc….

Mikrotik ROS V 5.x & 6.x

Step 1
Address
Step 2
Firewall_Nat
Step 3
IP_Pool
Step 4
Hotspot_Shared_Profile
Step 5
Hotspot_User_with_Profile
Step 6
Hotspot_User
Step 7
Simple_Queues

Now create a script called que-to-0

script_queue-to-0


/que simple move [find name="Group-A"] [:pick [find] 0]
/que simple move [find name="Group-B"] [:pick [find] 1]

OR

ROS CLI Script for teminal window


/system script

add name=que-to-0 policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source="/que simple move [find name=\"Group-A\"] [:pick [find] 0]\r\
    \n/que simple move [find name=\"Group-B\"] [:pick [find] 1]"

How to run this script ?

There was 2 way to run this script

Scenario 1

I am adding script run command in Hotspot User Profile Script Section.

Hotspot_User_with_Profile_Script

Scenario 2

Another way is create a Schedule to run this script ..

Schedule_Script

Few things to understand in IP/29 giving in Simple Queues

You can do more with this work scenario.

Best Regard’s
Abubaker Siddiq Lasania
Virtual IT Support

Join in @ Page / Group

Vlan Switch setup in Mikrotik Router Board.


Recently i have configure Mikrotik Router Board 450g & 750Gl as Vlan Switch.
Before Vlan

Router Board 450g

Router Board 450g

Ether2 is master port for trunking and Ether Port 3,4,5 is a switch port manageable work independently.

Before setup you need to reset router and remove all default configuration.

Now Connect pc Lan wire on Ether1 (Port 1)

Open Winbox and paste script on terminal line by line .

Setting Interface as Master.

/interface ethernet
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2
set [ find default-name=ether5 ] master-port=ether2


Now setting switch port. (Switch Port Chip Available in several model of Router Board )

you can change vlan id and you required setup vlan id in even numbers

/interface ethernet switch port
set 1 vlan-header=add-if-missing vlan-mode=secure
set 2 default-vlan-id=100 vlan-header=always-strip vlan-mode=secure
set 3 default-vlan-id=200 vlan-header=always-strip vlan-mode=secure
set 4 default-vlan-id=300 vlan-header=always-strip vlan-mode=secure


Now Setting Vlan Switching


/interface ethernet switch vlan
add ports=ether3,ether2 switch=switch1 vlan-id=100
add ports=ether4,ether2 switch=switch1 vlan-id=200
add ports=ether5,ether2 switch=switch1 vlan-id=300

After all setting you need to reboot router board .

After
vlan

InterVLAN-Routing

Best Regard’s
Abubaker Siddiq Lasania
Virtual IT Support

Join in @ Page / Group