2015 in review


The WordPress.com stats helper monkeys prepared a 2015 annual report for this blog.

Here’s an excerpt:

The concert hall at the Sydney Opera House holds 2,700 people. This blog was viewed about 60,000 times in 2015. If it were a concert at Sydney Opera House, it would take about 22 sold-out performances for that many people to see it.

Click here to see the complete report.

HOW TO SETUP BURSTED PROFILE IN MIKROTIK


Brust_Profile1

Brust_Profile2


means:
Rate:300k/800k
Burst Rate: 300k/1000k
Burst Threshold: 300k/900k
Burst Time: 30/30
Priority: 8
Minimum rate: 300k/768k

Brust_Queue1

Brust_Queue2

Best Regard’s
Abubaker Siddiq Lasania
Virtual IT Support

Join in @ Page / Group

Access Mikrotik Remotely


Method to access Load Balance + User Server via remotely. IF you have only 1 server .. no need to setup any thing accept port forwarding in adsl modem i.e 8291 in advance section / virtual server or NAT DMZ  set (Mikrotik) WAN IP. (192.168.1.2)

Quick Note for Beginners:

Option 1
Before you start below method you need Need Static IP Address ( WAN )

Option 2

Before you start below method you need Dynamic IP Updater Script to update your IP Address ( WAN )

Free Dynamic IP updater for Mikrotik

1. ChangeIP.com
2. no-ip.com

You can use any 1 of them to update your dynamic IP.

Step 1
9kuiv7.jpg

Step 2

ma8fiw.jpg

Open 1st router (Load Balance)

Goto IP Services

Change Winbox port 8291 -> 8292

router1_service

Goto IP FIREWALL NAT ( Load Balance )

fwd1

Set to address ( Next Server Wan IP )

fwd2

How to check winbox port are open ?

open your browser and type http://ping.eu/port-chk

ping.eu_portcheck1

ping.eu_portcheck2

Best Regard’s
Abubaker Siddiq Lasania
Virtual IT Support

Join in @ Page / Group

Skype Logo

How to stop advertisement in Skype


How to stop advertisement in Skype


/ip dns static
add address=127.0.0.1 name=pubads.g.doubleclick.net
add address=127.0.0.1 name=static.doubleclick.net
add address=127.0.0.1 name=devads.skypeassets.net
add address=127.0.0.1 name=devapps.skype.net
add address=127.0.0.1 name=qawww.skypeassets.net
add address=127.0.0.1 name=qaapi.skype.net
add address=127.0.0.1 name=preads.skypeassets.net
add address=127.0.0.1 name=preapps.skype.net
add address=127.0.0.1 name=static.skypeassets.com
add address=127.0.0.1 name=serving.plexop.net
add address=127.0.0.1 name=preg.bforex.com
add address=127.0.0.1 name=ads1.msads.net
add address=127.0.0.1 name=flex.msn.com
add address=127.0.0.1 name=apps.skype.com
add address=127.0.0.1 name=api.skype.com
add address=127.0.0.1 name=cdn.mbstatic.org
add address=127.0.0.1 name=marathonbet.com
add address=127.0.0.1 name=megogo.net
add address=127.0.0.1 name=adselector.ru
add address=127.0.0.1 name=pluso.ru
add address=127.0.0.1 name=flash.begun.ru
add address=127.0.0.1 name=ad.adriver.ru

Best Regard’s
Abubaker Siddiq Lasania
Virtual IT Support

Join in @ Page / Group

Multiple Server in Mikrotik


Yes you can do Hotspot / PPP / DHCP in each interface as you like.

Multiple combination also work without hesitation.

In above picture i am simply configure multiple dhcp servers on each ethernet interface.

Step 1

Change Interface name
ether1 as WAN
ether2 as Lan1
ether3 as Lan2
ether4 as Lan3
ether5 as Lan4

Step 2
Goto IP Address
Add Wan IP address
Add Lan1 IP address as 10.0.1.1/24
Add Lan2 IP address as 10.0.2.1/24
Add Lan3 IP address as 10.0.3.1/24
Add Lan4 IP address as 10.0.4.1/24

Step 3
Goto IP Dhcp-Server
In Dhcp-Server Dhcp tab
Click on Dhcp Setup
1

2

3

4

5

6

7

8

Repeat same for other interface.

Step 4

In IP Firewall nat

add masquerade rule for local subnets and set out interface as wan.

i hope you will get some basic information about to setup multiple dhcp server on each interface on Mikrotik router.

Best Regard’s
Abubaker Siddiq Lasania
Virtual IT Support

Join in @ Page / Group

Block Teamviewer Connections on Mikrotik


Here is a guide how to block Team Viewer connection

/ip firewall address-list
add address=92.51.128.0/18 comment=Teamviewer_Server list=Teamviewer
add address=37.48.64.0/18 comment=Teamviewer_Server list=Teamviewer
add address=217.146.26.0/24 comment=Teamviewer_Server list=Teamviewer
add address=88.198.0.0/16 comment=Teamviewer_Server list=Teamviewer
add address=37.252.253.0/24 comment=Teamviewer_Server list=Teamviewer
add address=178.255.155.0/24 comment=Teamviewer_Server list=Teamviewer
add address=159.8.64.0/18 comment=Teamviewer_Server list=Teamviewer
add address=178.77.64.0/18 comment=Teamviewer_Server list=Teamviewer


/ip firewall filter
add action=drop chain=forward comment="Drop all traffic from address on \\ Teamviewer \\ address list" src-address-list=Teamviewer
add action=drop chain=input comment="Drop all traffic from address on \\ Teamviewer \\ address list" src-address-list=Teamviewer

With these two settings, your router will ignore any client not getting response from Team Viewer.

Best Regard’s
Abubaker Siddiq Lasania
Virtual IT Support

Join in @ Page / Group

Block Static IP users in DHCP


1. Set arp=reply-only on the interface your customers are connecting to.

2. Set add-arp=yes for the DHCP-Server.

With these two settings, your router will ignore any client who had not obtained an IP address from the DHCP server.

Best Regard’s
Abubaker Siddiq Lasania
Virtual IT Support

Join in @ Page / Group

Block WhatsApp Messenger in Mikrotik


WhatsApp

Copy Below address and paste into terminal to block access of Whatsapp Messenger completely..


/ip firewall address-list
add address=31.13.64.51 list=Whatsapp
add address=31.13.65.49 list=Whatsapp
add address=31.13.66.49 list=Whatsapp
add address=31.13.67.51 list=Whatsapp
add address=31.13.69.240 list=Whatsapp
add address=31.13.70.49 list=Whatsapp
add address=31.13.71.49 list=Whatsapp
add address=31.13.72.52 list=Whatsapp
add address=31.13.73.49 list=Whatsapp
add address=31.13.74.49 list=Whatsapp
add address=31.13.75.52 list=Whatsapp
add address=31.13.76.81 list=Whatsapp
add address=31.13.77.49 list=Whatsapp
add address=31.13.79.195 list=Whatsapp
add address=31.13.80.53 list=Whatsapp
add address=31.13.81.53 list=Whatsapp
add address=31.13.82.51 list=Whatsapp
add address=31.13.83.51 list=Whatsapp
add address=31.13.84.51 list=Whatsapp
add address=31.13.85.51 list=Whatsapp
add address=31.13.86.51 list=Whatsapp
add address=31.13.87.51 list=Whatsapp
add address=31.13.88.49 list=Whatsapp
add address=31.13.88.57 list=Whatsapp
add address=31.13.90.51 list=Whatsapp
add address=31.13.91.51 list=Whatsapp
add address=31.13.92.52 list=Whatsapp
add address=31.13.93.51 list=Whatsapp
add address=31.13.95.63 list=Whatsapp
add address=50.22.75.192/27 list=Whatsapp
add address=50.22.93.192/27 list=Whatsapp
add address=50.22.198.204/30 list=Whatsapp
add address=50.22.210.32/30 list=Whatsapp
add address=50.22.210.128/27 list=Whatsapp
add address=50.22.225.64/27 list=Whatsapp
add address=50.22.235.248/30 list=Whatsapp
add address=50.22.240.160/27 list=Whatsapp
add address=50.23.90.128/27 list=Whatsapp
add address=50.97.57.128/27 list=Whatsapp
add address=75.126.39.32/27 list=Whatsapp
add address=108.168.174.0/27 list=Whatsapp
add address=108.168.176.192/26 list=Whatsapp
add address=108.168.177.0/27 list=Whatsapp
add address=108.168.180.96/27 list=Whatsapp
add address=108.168.254.65 list=Whatsapp
add address=108.168.255.224 list=Whatsapp
add address=108.168.255.227 list=Whatsapp
add address=158.85.0.96/27 list=Whatsapp
add address=158.85.5.192/27 list=Whatsapp
add address=158.85.46.128/27 list=Whatsapp
add address=158.85.48.224/27 list=Whatsapp
add address=158.85.58.0/25 list=Whatsapp
add address=158.85.61.192/27 list=Whatsapp
add address=158.85.224.160/27 list=Whatsapp
add address=158.85.233.32/27 list=Whatsapp
add address=158.85.249.128/27 list=Whatsapp
add address=158.85.249.224/27 list=Whatsapp
add address=158.85.254.64/27 list=Whatsapp
add address=169.53.29.128/27 list=Whatsapp
add address=169.53.71.224/27 list=Whatsapp
add address=169.53.250.128/26 list=Whatsapp
add address=169.54.2.160/27 list=Whatsapp
add address=169.54.51.32/27 list=Whatsapp
add address=169.54.55.192/27 list=Whatsapp
add address=169.54.210.0/27 list=Whatsapp
add address=169.54.222.128/27 list=Whatsapp
add address=169.55.69.128/26 list=Whatsapp
add address=169.55.74.32/27 list=Whatsapp
add address=169.55.235.160/27 list=Whatsapp
add address=173.192.162.32/27 list=Whatsapp
add address=173.192.219.128/27 list=Whatsapp
add address=173.192.222.160/27 list=Whatsapp
add address=173.192.231.32/27 list=Whatsapp
add address=173.193.205.0/27 list=Whatsapp
add address=173.193.230.96/27 list=Whatsapp
add address=173.193.230.128/27 list=Whatsapp
add address=173.193.230.192/27 list=Whatsapp
add address=173.193.239.0/27 list=Whatsapp
add address=174.36.208.128/27 list=Whatsapp
add address=174.36.210.32/27 list=Whatsapp
add address=174.36.251.192/27 list=Whatsapp
add address=174.37.199.192/27 list=Whatsapp
add address=174.37.215.28/30 list=Whatsapp
add address=174.37.217.64/27 list=Whatsapp
add address=174.37.231.64/27 list=Whatsapp
add address=174.37.243.64/27 list=Whatsapp
add address=174.37.251.0/27 list=Whatsapp
add address=179.60.192.51 list=Whatsapp
add address=179.60.193.51 list=Whatsapp
add address=179.60.195.51 list=Whatsapp
add address=184.173.73.176/28 list=Whatsapp
add address=184.173.136.64/27 list=Whatsapp
add address=184.173.147.32/27 list=Whatsapp
add address=184.173.161.64 list=Whatsapp
add address=184.173.161.160/27 list=Whatsapp
add address=184.173.173.116 list=Whatsapp
add address=184.173.179.32/27 list=Whatsapp
add address=184.173.195.32/27 list=Whatsapp
add address=184.173.201.32/27 list=Whatsapp
add address=184.173.204.32/27 list=Whatsapp
add address=184.173.250.53 list=Whatsapp
add address=192.155.212.192/27 list=Whatsapp
add address=198.11.193.182/31 list=Whatsapp
add address=198.11.212.0/27 list=Whatsapp
add address=198.11.217.192/27 list=Whatsapp
add address=198.11.251.32/27 list=Whatsapp
add address=198.23.80.0/27 list=Whatsapp
add address=198.23.86.224/27 list=Whatsapp
add address=198.23.87.64/27 list=Whatsapp
add address=208.43.115.192/27 list=Whatsapp
add address=208.43.117.79 list=Whatsapp
add address=208.43.117.136 list=Whatsapp
add address=208.43.122.128/27 list=Whatsapp

/ip firewall filter
add chain=forward dst-address-list=Whatsapp action=drop comment="Whatsapp Drop"
add chain=input src-address-list=Whatsapp action=drop comment="Whatsapp Drop"

Best Regard’s
Abubaker Siddiq Lasania
Virtual IT Support

Join in @ Page / Group

OpenDns Dynamic Update Script


After a long time now OpenDns Dynamic IP Update script is now available in OpenDns Support section for Mikrotik ..

I have test this script in Mikrotik version 5.x & 6.x

OpenDns work like a charm .. to block several categories of Internet Section .. you can block Porn Website / Media Shrining / any website you want.

Create a free account in OpenDns website and follow instruction.

Copy Below Script in notepad and edit 4 section.


1. email@address.com
2. update-only-password
3. networkname
4. ether1

script_change

#--------------- Change Values in this section to match your setup ------------------

# User account info of OpenDNS

# Update-only password (obtained from OpenDNS Support). With two-factor authentication enabled, the use of an update only password is required. 

:local odnsuser "email@address.com"
:local odnspass "update-only-password"

# Set the hostname or label of network to be updated. This is the name of your OpenDNS network on the Dashboard. 
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host name.
# Only one host is supported
# Use "all.dnsomatic.com" for the matichost to update all items in dnsomatic with this IP.

# Note, you must have admin or edit (Read/Write/Grant in the OpenDNS Dashboard) to update IP addresses. 

:local odnshost "networkname"

# Change to the name of interface that gets the changing IP address

# May not be needed for your model number - commenting out this line may still work for single interface devices or if this is not supplied in the DNS-O-Matic script currently being used

:local inetinterface "ether1"

#------------------------------------------------------------------------------------

# No more changes needed, one optional change

:global previousIP;

:log info "Fetching current IP"

# Get the current public IP using DNS-O-Matic service.
/tool fetch url="http://myip.dnsomatic.com/" mode=http dst-path=mypublicip.txt

# Read the current public IP into the currentIP variable.
:local currentIP [/file get mypublicip.txt contents]

:log info "Fetched current IP as $currentIP"

# --------- Optional check to only run if the IP has changed (one line: :if)

# to disable, set line below to: ":if ($currentIP != 1) do={"

:if ($currentIP != $previousIP) do={
:log info "OpenDNS: Update needed"
:set previousIP $currentIP

# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
:local url "http://updates.opendns.com/nic/update\3Fhostname=$odnshost"
:log info "OpenDNS: Sending update for $odnshost"

/tool fetch url=($url) user=$odnsuser password=$odnspass mode=http dst-path=("/net_odns.txt")

:delay 2;

:local odnsReply [/file get net_odns.txt contents];

:log info "OpenDNS update complete."

:log info "OpenDNS reply was $odnsReply";

} else={

:log info "OpenDNS: Previous IP $previousIP and current IP equal, no update need"
}


Make
OpenDns

Put the above script on Mikrotik Users Server .. i you setup this in Load balancer won’t work as you required to do …

Please Note Change DNS setting Mikrotik DNS to 208.67.222.222 , 208.67.220.220

Best Regard’s
Abubaker Siddiq Lasania
Virtual IT Support

Join in @ Page / Group